MSTP (Multiple Spanning Tree Protocol)

Continuando con la implementación mostrada en la entrada anterior y considerando la topología mostrada en la Figura 1, que puede ser descargada aquí, implementaremos el protocolo MSTP en switches de la marca Huawei y apreciaremos sus diferencias respecto al resto de protocolos STP.

Figura 1: Topología STP
Paso 1: Creación de VLANs
Para evidenciar el comportamiento de MSTP, crearemos el rango de VLANs 2 a la 20 en todos los switches, tal como se muestra a continuación.
SW1 a SW4
vlan batch 2 to 20
Paso 2: Creación de los enlaces troncales

Ahora, declaramos todas las interfaces como troncales y permitimos el rango de las VLANs creadas en dichos enlaces.

SW1 y SW2

interface GigabitEthernet 0/0/9
 port link-type trunk
 port trunk allow-pass vlan 1 to 20

interface GigabitEthernet 0/0/10
 port link-type trunk
 port trunk allow-pass vlan 1 to 20

interface GigabitEthernet 0/0/13
 port link-type trunk
 port trunk allow-pass vlan 1 to 20

interface GigabitEthernet 0/0/14
 port link-type trunk
 port trunk allow-pass vlan 1 to 20

SW3

interface GigabitEthernet 0/0/1
 port link-type trunk
 port trunk allow-pass vlan 1 to 20

interface GigabitEthernet 0/0/13
 port link-type trunk
 port trunk allow-pass vlan 1 to 20

interface GigabitEthernet 0/0/23
 port link-type trunk
 port trunk allow-pass vlan 1 to 20

SW4

interface GigabitEthernet 0/0/1
 port link-type trunk
 port trunk allow-pass vlan 1 to 20

interface GigabitEthernet 0/0/14
 port link-type trunk
 port trunk allow-pass vlan 1 to 20

interface GigabitEthernet 0/0/24
 port link-type trunk
 port trunk allow-pass vlan 1 to 20
Paso 3: Configuración de MSTP

A continuación, cambiaremos el modo STP a MSTP; y luego crearemos una región MSTP con dos instancias: la primera de ellas para las primeras 10 VLANs y la segunda para las 10 VLANs restantes.

SW1 al SW4

stp mode mstp

stp region-configuration
 region-name REGION1
 instance 1 vlan 1 to 10
 instance 2 vlan 11 to 20
 active region-configuration

Luego, verificamos la correspondencia de las VLANs a las instancias MSTP recientemente creadas, tal como se muestra en la figura 2. Nótese que aparece la instancia 0 a pesar de no haber sido configurada, debido a que es la instancia por defecto, la cual agrupa a todas las VLANs que no hayan sido incluidas en otras instancias.

Figura 2: Correspondencia de VLANs a las instancias MSTP

A partir de esta correspondencia, podemos afirmar que se realizará sólo un proceso STP para las VLANs 1 a la 10, y otro proceso STP para las VLANs 2 a la 20. De esta manera, no se realizará cálculos innecesarios para cada VLANs. Dicho ahorro de procesamiento es la principal ventaja de MSTP.

Paso 4: Elección del root bridge

Ahora elegiremos, a través de la modificación de las prioridades, al switch SW1 como el root bridge primario para la instancia 1 y como root bridge secundario para la instancia 2.

SW1

stp instance 1 priority 4096
stp instance 2 priority 8192

Asimismo, elegimos al switch SW2 como el root bridge primario para la instancia 2 y como root bridge secundario para la instancia 1.

SW2

stp instance 2 priority 4096
stp instance 1 priority 8192

En las figuras 3 y 4 corroboramos que se ha logrado lo indicado.

Figura 3: Switch SW1 como root bridge de la instancia 1
Figura 4: Switch SW2 como root bridge de la instancia 2

De igual manera, puede apreciarse que los roles de los puertos a nivel de STP en todos los switches dependen de la instancia de análisis. Como ejemplo, se muestra las figuras 5 y 6, en las que aparecen todos los puertos con el rol de designado si el switch ha sido elegido como root bridge en la instancia respectiva.

Figura 5: Rol STP de los puertos del switch SW1 en cada instancia
Figura 6: Rol STP de los puertos del switch SW2 en cada instancia
A manera de práctica, usando el comando display stp instance brief en todos los switches, puede obtener la topología STP para cada instancia, teniendo en consideración que la conexión de todos los switches que no son root bridge hacia su respectivo root bridge se realiza a través de los puertos con el rol de root.

Con esto hemos concluido la implementación estándar de STP, RSTP y MSTP. En la siguiente entrada implementaremos el emulador EVE en una infraestructura en la nube.

Deja un comentario

Nos gustaría saber tu opinión